Kibana 6.2.4 stopped working after x-pack installation


#1

I have installed elasticstack 6.2.4 on a single server. I was able to send data to elasticsearch and also got index created. I wanted to integrate this setup with x-pack for ML and monitoring purpose. Was able to install and configure x-pack for elasticsearch. But when i installed x-pack for kibana it started throwing below error after service restart

Uncaught Error: [$injector:unpr] Unknown provider: sessionTimeoutProvider <- sessionTimeout <- $http <- config kibana

This error comes when i open kibana URL on the browser. Then i following this link(https://github.com/elastic/kibana/issues/9369) and deleted optimize folder from /usr/share/kibana now i am getting below error on the broswer

Kibana did not load properly. Check the server output for more information.

and below error on the logs of kibana

  return binding.open(pathModule._makeLong(path), stringToFlags(flags), mode);
                 ^

Error: EACCES: permission denied, open '/usr/share/kibana/optimize/.babelcache.json'
    at Error (native)
    at Object.fs.openSync (fs.js:642:18)
    at Object.fs.writeFileSync (fs.js:1356:33)
    at save (/usr/share/kibana/node_modules/babel-register/lib/cache.js:45:16)
    at _combinedTickCallback (internal/process/next_tick.js:73:7)
    at process._tickCallback (internal/process/next_tick.js:104:9)
    at Module.runMain (module.js:613:11)
    at run (bootstrap_node.js:387:7)
    at startup (bootstrap_node.js:153:9)
    at bootstrap_node.js:500:3

I granted permission but didnt help bringing the node up. Please help me with this.

Do i need to enable something with respect to x-pack before bringing up kibana?


#2

I was able to solve this by removing previous kibana installation completely and installed it again. Then before starting the service i installed x-pack for kibana using kibana-plugin install . Now when i started kibana i got the kibana dashboard with x-pack installed and i didnt eved needed to remove optimize files.


(Brandon Kobel) #3

Hey @frasmd, thanks for sharing your solution here, it'll help others that are in a similar position.