Kibana 6.3.2 does not work on ipv6


(Валера Носиков) #1

Kibana version: 6.3.2 OSS
Elasticsearch version: 6.3.2 OSS

Elasticsearch and kibana are located on the same hosts

my properties on kibana.yml file:

elasticsearch.url: "http://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:9201"
server.host: "fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b"
server.port: 5601

i have this error on browser when i open any kibana plugins:

ERROR: 2019-03-11T10:43:22Z
  Error: Request error, retrying
  POST https://fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b:5601/elasticsearch/_msearch => Failed to execute 'open' on 'XMLHttpRequest': Invalid URL
      at Log.error (https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:162:80027)
      at checkRespForFailure (https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:162:88597)
      at https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:162:98978
      at processQueue (https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:125:134252)
      at https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:125:135201
      at Scope.$digest (https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:125:146077)
      at https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:125:148581
      at completeOutstandingRequest (https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:125:37082)
      at https://[fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b]:5601/bundles/vendors.bundle.js?v=17307:125:40220

Also Kibana devTools working. I think that something wrong with elasticsearch ui client or proxy.
This is bug? or not?
I haven't opportunity to use ipv4 network.
Please, help me.


(Joe Fleming) #2

This issue talks about the server not binding to the IPv6 localhost address, but that's a difference use case, you're setting the host to the IPv6 address.

It may be related to this addressing fix which looks like will be part of v7.0.0 of the stack, but wasn't backported to any 6.x version. It may be worthwhile following up on that PR and asking about a backport.


(Валера Носиков) #3

I tried different host configurations.

  • with [::0]
  • with bind name in /etc/hosts . Like this :fd95:ff55:7fb8:f1e5:f816:3eff:feed:ce5b elk-network-host

none of them worked.

if this is useful, I also use ssl.


(Валера Носиков) #4

Oh. If I change the kibana code as specified in that FIX.

Everything works!!!

Where do I go to get a fix for the 6.3.2 version of Kibana?


(Joe Fleming) #5

Where do I go to get a fix for the 6.3.2 version of Kibana?

You'd have to roll your own build with that fix in it. I don't think there will be any more 6.3 releases at all, so even if this was backported, you'd still need to upgrade to 6.6 or 6.7 (depending on when that release is cut).

I added a comment to the PR that fixed it to see why it wasn't made available in any 6.x version, feel free to follow up or plead the case for backporting there.


(system) closed #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.