Kibana "bettermap" widget


(Steven Pisarski) #1

Hello,

I have been trying to configure a bettermap widget in Kibana using some
custom (non Logstash) data but the widget never renders the map and only
shows a graphic making one believe it is working. I have tested the curl
command issued by bettermap which appears to be working properly. The
"Coordinate Field" value is "pin.location" which should be setup properly
as an array ([lon,lat]) as this field contains data like, "pin.location" :
[ "[-73.630000,42.680000]" ].

I understand that this widget is experimental; however, is it only designed
to work with Logstash? If not, are there any other bettermap reference
documents than on the ES site because that page is extremely lean and I
have exhausted all of my other options.

Best,
Steve

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/25e021eb-ea15-4441-905f-c98d7fd794c7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(shikha) #2

Hello, i think pin.location must like this: location: [-0.125532746315002,51.5084152563931], then must work..

I am also want some help from Kibana usersteam, i am showing location in bettermap, but i want to connect them by some line, Is it possible in bettermap? Please tell me asap


(ElasticSearch Users mailing list) #3

The field has to be a numeric type (for example, double) containing 2
values in lon, lat sequence. Try double checking your mapping to make sure
it is not a string or something else.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2b373d70-1311-429d-9f79-aa26a9548a95%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Steven Pisarski) #4

Thanks Binh for the reply,

I cannot see any way ES would view the long/lat values as strings and had
also tried other geoip standards to no avail. My biggest issue is the
terrible or non-existent messages from ES or Kibana that could help shed
light on the issue. I guess bettermap is truly experimenal and not really
worth my time banging my head against my desk at this time. I will continue
to try and find better options (maybe not cheaper) during my
discover/prototyping stage.

Best,
Steve

On Friday, May 30, 2014 3:34:30 PM UTC-6, Binh Ly wrote:

The field has to be a numeric type (for example, double) containing 2
values in lon, lat sequence. Try double checking your mapping to make sure
it is not a string or something else.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/50a0a4f0-5801-4bdb-8305-237ff7d248fa%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(ElasticSearch Users mailing list) #5

Steve, if you can show a copy of your mapping here, I can take a quick look.

curl localhost:9200/your_index/_mapping?pretty

It should work fine, the only time it doesn't work for me is when I messed
up in the mapping.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8236faac-4858-425a-88fe-14532873e119%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Steven Pisarski) #6

Thanks so much for the tip! You were correct as did format my location
incorrectly.

On Monday, June 2, 2014 12:51:28 PM UTC-6, Binh Ly wrote:

Steve, if you can show a copy of your mapping here, I can take a quick
look.

curl localhost:9200/your_index/_mapping?pretty

It should work fine, the only time it doesn't work for me is when I messed
up in the mapping.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/54b77c66-8d61-4c60-8970-caed98d767c2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #7