Kibana can not refresh tempalte field

Hi, I am meeting a problem.
The first time I used filebeat default template to push nginx log to elasticsearch.
And I add some new fields to the template later. I could see that the template had refresh.
But kibana still warning that the newly added field have no mapping.
I had tried refresh index, flush index, etc inside Index Management.
I also tried delete index and re-push log. All not work...
Anybody know how to refresh the templates correctly?
thank you


Just to confirm, you've tried clicking the refresh button that I've highlighted in red below? Have you tried deleting and recreating the kibana index pattern (not the index itself)? If so, can you find the field you're looking for in the field list on the page I've shown in the screenshot below? If so, what does it look like?

Ar yes. So silly I am :joy:
After I refresh index pattern. The problem resolved.
Great thanks for your help.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.