Kibana date_nanos generate CSV - TypeError: FieldFormat is not a constructor

On Discover, click Share, CSV - getting "TypeError: FieldFormat is not a constructor" if one of the fields in kibana pattern is set to date_nanos. resetting kibana field type to Date fixes the problem, but also trim digits past 1ms, so the data is sorted incorrectly.
Date_nanos does not allow to specify formatting on index pattern in Kibana. There is default setting in advanced menu for kibana, but that seems to have to effect on the above error.
Running ELK 7.3.1

please advise if there is any workaround and whether this is a known issue.

Hi, thank you for reporting this.
I can confirm, that this doesn't work in 7.3.1. In my current dev version this is fixed, so it should be fixed in 7.4.0, I will check this.

I've successfully exported csv files containing date_nanos in our upcoming 7.4 release. So the issue has already been fixed.

confirmed - the issue is fixed in 7.4.0. thank you!!!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.