Kibana developer guide

I ran 'yarn kbn bootstrap' while looking at the kibana developer guide, and the error follows.

    at Process.ChildProcess._handle.onexit (node:internal/child_process:285:19)
    at onErrorNT (node:internal/child_process:485:16)
    at processTicksAndRejections (node:internal/process/task_queues:83:21)
error Command failed with exit code 1.
info Visit for documentation about this command.

The path to "git" is also set. Please tell me the cause of the error and the solution.

Hi @dms6978

Which OS are you using?

I see a similar issue has been raised previously. As per that thread, can you try running npm install first?

I'm using MacOS Apple silicon Ventura.
The following error occurs when running with the command npm install.

npm ERR! Unsupported URL Type "link:": link:x-pack/test/alerting_api_integration/common/plugins/aad

Last night yarn kbn bootstrap worked, but it's not working today :smiling_face_with_tear:

Appreciate the update. Are you getting a particular error running yarn kbn bootstrap today?

I would be tempted to try clearing the cache by running yarn cache clean, pull the latest version and then run the bootstrap and start commands again.

The same error continues to occur. It's hard..... what should I do.....?

I don't know what caused it to run, but I reconnected the repository using 'github DeskTop', and I updated it through the yarn command before running yarn kbn bootstrap and it worked!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.