Kibana developlent environment failes


#1

I'm trying to install the development environment of kibana, but I always get the same error.

error PATH/kibana/node_modules/geckodriver: Command failed.
Exit code: 1
Command: node index.js
Arguments:
Directory: PATH/kibana/node_modules/geckodriver
Output:
Downloading geckodriver...
events.js:183
      throw er; // Unhandled 'error' event
      ^
RequestError: connect ECONNREFUSED 192.30.253.112:443
    at ClientRequest.<anonymous> (PATH/kibana/node_modules/geckodriver/node_modules/got/index.js:69:21)
    at Object.onceWrapper (events.js:315:30)
    at emitOne (events.js:116:13)
    at ClientRequest.emit (events.js:211:7)
    at TLSSocket.socketErrorListener (_http_client.js:387:9)
    at emitOne (events.js:116:13)
    at TLSSocket.emit (events.js:211:7)

[bootstrap] failed:

Error: Command failed: yarn install --non-interactive --mutex file
    at makeError (PATH/kibana/packages/kbn-pm/dist/index.js:39003:9)
    at Promise.all.then.arr (PATH/kibana/packages/kbn-pm/dist/index.js:39108:16)
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:188:7)
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

Do you know how to fix this?
Thanks


(Tyler Smalley) #2

192.30.253.112 appears to be Github. Can you verify you have internet access on the machine. Do you require a proxy?


#3

I have internet access, it's the only package that fails.
And proxies are set as environment variables (in this way I downloaded all the other packages...)

export http_proxy=http://user:psw@proxy_addr:proxy_port
export https_proxy=http://user:psw@proxy_addr:proxy_port

and I tried also to set them in nmp properties

npm set https-proxy http://user:psw@proxy_addr:proxy_port
npm set http http://user:psw@proxy_addr:proxy_port

(Tyler Smalley) #4

Looks like this could be related: https://github.com/mozilla/geckodriver/issues/840


#5

Indeed, it looks related, but unfortunately it's still not clear if it's an infrastructure problem or something else.


#6

Still can't figure out how to solve this. If i try to reach 192.30.253.112 using a browser it tells me that the connection is not private, there should be some issue with the certificates. However I tried to set strict-ssl to false in yarn configuration but still with no success.

Don't have other ideas on how to proceed.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.