Kibana did not load properly


#1

Here's the full message:

Kibana did not load properly. Check the server output for more information.

I'm using Kibana 5.0.0 on a Debian machine with Elasticsearch 5.0.0. Elasticsearch is running fine on localhost:9200 (reachable and responding) and is hooked with a Logstash instance.

Logstash and Elasticsearch communicate well (tried a test with stdout). Also, Kibana is set to use Elasticsearch on kibana.yml.

The problem is with Kibana. When I launch it on localhost:5601, the only thing I've got is that error message.

I could'nt find anything in the logs. I've actually set a log output with logging.dest, and nothing strange shows up (I've even tried with logging.verbose).

Any idea?

Thank you.

UPDATE: Alright, that's was my fault; I was running ELK on a virtual machine, and trying to access Kibana from the host machine. And since localhost:5601 was not responding on the host machine (by default, Kibana is not accessible from outside, unless you set server.host to a non-loopback address), I've used a redirection on an Apache instance I've got on the guest machine to get localhost:8080/kibana (from the host machine) to launch localhost:5601 (on the second machine). And that's why Kibana refused to work, because it couldn't load its ressources properly.


(system) #2