Kibana error - ElasticSearchParseException related to date field


(Andra Bennett) #1

Hello,

I would appreciate some help with the following date parse error.

I have a date mapping defined with the @Field annotation as follows:

@Field(type =
org.springframework.data.elasticsearch.annotations.FieldType.Date, format =
DateFormat.custom, pattern="yyyy-MM-dd HH:mm:ss")

private String loggedTime;

The data gets inserted into elastic search just fine, but when I load
kibana3 with an table to display fields I get the following error:

Oops! ElasticSearchParseException[failed to parse date field
[2013-12-07T01:02:31.880Z], tried both date format [yyyy-MM-dd HH:mm:ss],
and timestamp number]

The date mentioned in the error [2013-12-07T01:02:31.880Z] is part of the
custom time filter enabled (I don't have control over its format, enabled
it using the kibana interface).

The other relevant kibana configuration are the time picker settings -
which refer to the loggedTime field with the mapping above, and the default
relative and auto-refresh options mentioned.

I tried the kibana index settings with "day" and "hour", "none"
timestamping and the index pattern to [anoraklogs-]YYYY-MM-DD HH:mm:ss
(since that matches the time stamp mapping above).

I do not have the _timestamp field enabled in my index.

Is the error message related to a bad configuration in elastic search or
the kibana dashboard? Seems like it's trying to parse the time filter range
with the format defined in the mapping… How else can I specify the kibana
time filter to comply?

Thanks,

Andra

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/10d4eb08-ce40-4b0f-ac52-aa4c604ecbff%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #2