Kibana fails in talking to Tribe Node


(Abigail) #1

Hi,

I have two ElasticSearch clusters and one tribe node for searching across
the two clusters. And there is a kibana 4 connects to the tribe node. What
I have done are:

  1. Created .kibana and kibana-int manually in the cluster
  2. Launch kibana
  3. Got to the screen "Configure an index pattern", hit the create button

Kibana loads then throws "MasterNotDiscoveredException[waited for [30s]]"
error.

It seems a known issue. I also tried adding "tribe.blocks.write: false"
into tribe node config file without any luck. I am sure saving dash board
will throw the same error. Can anyone help to confirm that if Kibana can
talk to tribe node? And anyone figure it out how to do it?

Thank you!
Abigail

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c0b2a218-572e-4e1f-929e-09852b847185%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Ramdev Wudali) #2

Hi Abigail;
Did you get any resolution on this issue ? I am in a similar situation
and would like to know if anything came of your investigations.

Thanks

Ramdev

On Tuesday, 24 March 2015 10:25:16 UTC-5, Abigail wrote:

Hi,

I have two ElasticSearch clusters and one tribe node for searching across
the two clusters. And there is a kibana 4 connects to the tribe node. What
I have done are:

  1. Created .kibana and kibana-int manually in the cluster
  2. Launch kibana
  3. Got to the screen "Configure an index pattern", hit the create button

Kibana loads then throws "MasterNotDiscoveredException[waited for [30s]]"
error.

It seems a known issue. I also tried adding "tribe.blocks.write: false"
into tribe node config file without any luck. I am sure saving dash board
will throw the same error. Can anyone help to confirm that if Kibana can
talk to tribe node? And anyone figure it out how to do it?

Thank you!
Abigail

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Abigail) #3

Hey Ramdev,

It works for us now. It has been a while. I think I did create .kibana
index manually and changed kibana to talk to a regular node first instead
of tribe node, after setting up, pointed kibana back to tribe node.

Hope this work for you.
Abigail

On Wednesday, May 13, 2015, Ramdev Wudali agastya71@gmail.com wrote:

Hi Abigail;
Did you get any resolution on this issue ? I am in a similar situation
and would like to know if anything came of your investigations.

Thanks

Ramdev

On Tuesday, 24 March 2015 10:25:16 UTC-5, Abigail wrote:

Hi,

I have two ElasticSearch clusters and one tribe node for searching across
the two clusters. And there is a kibana 4 connects to the tribe node. What
I have done are:

  1. Created .kibana and kibana-int manually in the cluster
  2. Launch kibana
  3. Got to the screen "Configure an index pattern", hit the create button

Kibana loads then throws "MasterNotDiscoveredException[waited for [30s]]"
error.

It seems a known issue. I also tried adding "tribe.blocks.write: false"
into tribe node config file without any luck. I am sure saving dash board
will throw the same error. Can anyone help to confirm that if Kibana can
talk to tribe node? And anyone figure it out how to do it?

Thank you!
Abigail

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/SsO3IBCz1U4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com
<javascript:_e(%7B%7D,'cvml','elasticsearch%2Bunsubscribe@googlegroups.com');>
.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAJNTK5-4qcAAXkn%2BWQtUpZ%3DY9NJ8REwNcz38ReF_nTBzejY3hg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Ramdev Wudali) #4

Hi Abigail:
yeah I had to do the same. I had to create the .kibana index, as well
as the mappings for visualization,dashboard,index-pattern and search
(refer to https://github.com/elastic/kibana/issues/3114 ) and the gist :
https://gist.github.com/rjosephwright/4ed7d4d25f89f83875db .
Also direct all write traffic to one ES Custer through some judicial use of
the tribe.blocks directive in the configuration.

to get it working. Its a rather hacky workaround to get it working
right.(either that or the implementation seems to be a bit thrown together.

Thanks for the response.

Cheers

Ramdev

On Thu, 14 May 2015 at 10:07 naye923 naye923@gmail.com wrote:

Hey Ramdev,

It works for us now. It has been a while. I think I did create .kibana
index manually and changed kibana to talk to a regular node first instead
of tribe node, after setting up, pointed kibana back to tribe node.

Hope this work for you.
Abigail

On Wednesday, May 13, 2015, Ramdev Wudali agastya71@gmail.com wrote:

Hi Abigail;
Did you get any resolution on this issue ? I am in a similar
situation and would like to know if anything came of your investigations.

Thanks

Ramdev

On Tuesday, 24 March 2015 10:25:16 UTC-5, Abigail wrote:

Hi,

I have two ElasticSearch clusters and one tribe node for searching
across the two clusters. And there is a kibana 4 connects to the tribe
node. What I have done are:

  1. Created .kibana and kibana-int manually in the cluster
  2. Launch kibana
  3. Got to the screen "Configure an index pattern", hit the create button

Kibana loads then throws "MasterNotDiscoveredException[waited for
[30s]]" error.

It seems a known issue. I also tried adding "tribe.blocks.write: false"
into tribe node config file without any luck. I am sure saving dash board
will throw the same error. Can anyone help to confirm that if Kibana can
talk to tribe node? And anyone figure it out how to do it?

Thank you!
Abigail

--
Please update your bookmarks! We have moved to
https://discuss.elastic.co/

You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/SsO3IBCz1U4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/SsO3IBCz1U4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAJNTK5-4qcAAXkn%2BWQtUpZ%3DY9NJ8REwNcz38ReF_nTBzejY3hg%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAJNTK5-4qcAAXkn%2BWQtUpZ%3DY9NJ8REwNcz38ReF_nTBzejY3hg%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7gsBEVWEvBuXCBZcxbxY-0mtNcJ54SkEiD2wZ1VwREz0Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #5