Kibana heap size


How can i increase the heap size memory for Kibana. I'm using the version 7.6.

I tried : export NODE_OPTIONS=--max-old-space-size=8000. It didn't work.

Anyone could help me on this.

Thanks !

The docs ( indicate that for deb and rpm installation, you would need to add it to /etc/default/kibana instead. Otherwise, what indicates that this setting isn't working?

1 Like


I already did that !

But in kibana's dashboard i can see that i have only 1.4GB of memory.

I see, that indicates that the setting is not working for you. Are you sure that you followed the directions at exactly, with no typos?

Something was wrong with Kibana's acces rights.
I added the folowing line to the "/etc/default/kibana" file :


And now it's working fine.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.