Kibana ingress not working after upgrading to eck 1.1.0

Hi Team,

My kibana ingress is not working after i upgraded to eck 1.1.0 from eck 1.0.1, below are the files for reference

kibana_cr.yaml

apiVersion: kibana.k8s.elastic.co/v1
kind: Kibana
metadata:
  name: kibana-config
spec:
  version: 7.4.0
  image: <custom-image>
  count: 1
  elasticsearchRef:
    name: "elasticsearch-config"
  http:
   service:
     spec:
       type: LoadBalancer
   tls:
     selfSignedCertificate:
       disabled: true
    # this shows how to customize the Kibana pod
    # with labels and resource limits
  podTemplate:
    metadata:
      labels:
        kibana: node
    spec:
      containers:
      - name: kibana
        resources:
          limits:
            memory: 1Gi
            cpu: 1
--- 
apiVersion: extensions/v1beta1
kind: Ingress
metadata:
  name: kibana-ingress
spec:
  rules:
  - http:
      paths:
      - path: /*
        backend:
          serviceName: kibana-config-kb-http
          servicePort: 5601

i cannot see any error in manifest but i am not able to view the webpage, the same config worked for previous release

one more thing , i am able to see kibana dashboard using load balancer url but not able to see the same from ingress, which means my application is up and fine and so is my service , but ingress is not able to fetch me the webpage

i am getting 502 error

can you please help me with this

Hi, this is possibly due to the Kibana readiness probe switching to an exec action in 1.1.0 (this was to support environments with strict network restrictions). Some ingress controllers require the probe to be an HTTP GET action in order to perform their own health checks. Try altering your Kibana manifest as follows:

apiVersion: kibana.k8s.elastic.co/v1
kind: Kibana
metadata:
  name: kibana-config
spec:
  version: 7.4.0
  image: <custom-image>
  count: 1
  elasticsearchRef:
    name: "elasticsearch-config"
  http:
   service:
     spec:
       type: LoadBalancer
   tls:
     selfSignedCertificate:
       disabled: true
    # this shows how to customize the Kibana pod
    # with labels and resource limits
  podTemplate:
    metadata:
      labels:
        kibana: node
    spec:
      containers:
      - name: kibana
        resources:
          limits:
            memory: 1Gi
            cpu: 1
        readinessProbe:
          httpGet:
            scheme: HTTPS
            path: "/login"
            port: 5601

Thank you so much charith, its working fine now :slight_smile: