Kibana is Not Loading Properly using Nginx reverse Proxy

I am hosting Kibana using Nginx reverse proxy but the in browser getting 404 /spaces/enter output.
Kibana is running on http://IP:5601
Elasticsearch Open on http://IP:9200
I am able to open Kibana on my servers using IP but not able to open using Domain.

My Nginx Configuration is
location /kibana/ {

            proxy_pass http://PrivateIP:5601/;

I had the same problems before so I decided to write whole blog post about setting Kibana on your own domain (as iframe).

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.