Kibana is not ready yet

Hi There,

I got the error when trying to start Kibana that there is a fatal error qserver.host setting was not applied?

Can you guys tell me what that means?

Hi @Pierrelaurent,

Could you please share the kibana logs for further investigation.

/var/log/kibana

Regards,
Harsh Bajaj

Hi,

The strange thing is that I do not have such a folder and logfile. Did the install didn't go wel and should I reinstall?

Hi @Pierrelaurent,

No, It doesn't mean that. You don't need to do re installation. However, You can set the log file path in kibana.yml file.

if you didn;t set log file path then you can check the logs in /var/log/messages file.

Please share kibana log while starting kibana service.

Regards,
Harsh Bajaja

Hi,

I have got logs now and it says No living connections, Unable to revive connection. It can't connect to Elastic search.

I checked IP settings, they seem to be allright

Do you want the raw logs?

Can you ping all of the nodes from your Kibana server? If you're using hostnames instead of IP addresses, make sure your DNS is resolving.

Hi @Pierrelaurent,

Yes, you are right it can't connect elasticsearch. Please check which is mentioned by @cbmurphy87 and also check that elasticsearch service is running properly or not.

Regards,
Harsh Bajaj

Hi @harshbajaj16

I pinged all hosts and they reply. I also have shutdown selinux and firewalld because this is in a test environment.

Regards

Make sure your versions match. Look in the Kibana log to see why it's not connecting to the nodes. If you have, for example, Elasticsearch 7.2 and Kibana 7.3, it will not be able to connect.

HI @Pierrelaurent,

Could you please paste the elasticsearch full logs /var/log/elasticsearch and also paste the kibana full logs ??

Regards,
Harsh Bajaj