Kibana is not working for public IP - throws FATAL { Error: listen EADDRNOTAVAIL


(Ritesh Sharma) #1

Hi People,
I am trying to start my kibana on public ip ( say, some_public_ip) but unable to do so , getting following error. Kindly Help !!

log [18:15:33.233] [info][status][plugin:timelion@5.5.2] Status changed from uninitialized to green - Ready
log [18:15:33.253] [fatal] Error: listen EADDRNOTAVAIL some_public_ip:5601
at Object.exports._errnoException (util.js:1018:11)
at exports._exceptionWithHostPort (util.js:1041:20)
at Server._listen2 (net.js:1245:19)
at listen (net.js:1294:10)
at net.js:1404:9
at _combinedTickCallback (internal/process/next_tick.js:83:11)
at process._tickCallback (internal/process/next_tick.js:104:9)
FATAL { Error: listen EADDRNOTAVAIL some_public_ip:5601
at Object.exports._errnoException (util.js:1018:11)
at exports._exceptionWithHostPort (util.js:1041:20)
at Server._listen2 (net.js:1245:19)
at listen (net.js:1294:10)
at net.js:1404:9
at _combinedTickCallback (internal/process/next_tick.js:83:11)
at process._tickCallback (internal/process/next_tick.js:104:9)
cause:
{ Error: listen EADDRNOTAVAIL some_public_ip:5601
at Object.exports._errnoException (util.js:1018:11)
at exports._exceptionWithHostPort (util.js:1041:20)
at Server._listen2 (net.js:1245:19)
at listen (net.js:1294:10)
at net.js:1404:9
at _combinedTickCallback (internal/process/next_tick.js:83:11)
at process._tickCallback (internal/process/next_tick.js:104:9)
code: 'EADDRNOTAVAIL',
errno: 'EADDRNOTAVAIL',
syscall: 'listen',
address: 'some_public_ip',
port: 5601 },
isOperational: true,
code: 'EADDRNOTAVAIL',
errno: 'EADDRNOTAVAIL',
syscall: 'listen',
address: 'some_public_ip',
port: 5601 }


(Mark Walkom) #2

Is that address assigned to the host Kibana is running on?


(Rohithnama) #3

I think you should enable the network host address in kibana.yml and for elasticsearch as well, if necessary.

Use your own IP or configure it to 0.0.0.0 (I had to do this when I'm running on AWS and to use the DNS IP) and it should work.

Note: maintain a space between networkhost: and the IP address as it will be viewed as a Key-Value pair.


(Ritesh Sharma) #4

Yes @warkolm , the specified public IP has been assigned to the same host where am trying to run a kibana.

@Rohithnama : actually am hosting kibana on my private cloud and server.host : "some_private_ip" has been already set in kibana.yml.


(Rohithnama) #5

As far as what I see, it definitely has to do something with the IP address that you are assigning. But I'm unable to figure out what the cause.

Let me know if you are able to sort out and if not, I hope other members will be able to help you!


(Mark Walkom) #6

You need to set that to the public IP, or 0.0.0.0 as advised.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.