EADDRNOTAVAIL on connecting remote kibana

Hi! im trying to connect remotely to a server in wich i´ve setup the ELK stash. Im currently running it on remote ubuntu 12.04, 4gb ram.
I started by looking for my public ip adress in order to modify my kibana.yml file, this is what i got:

so then i modified the yml file like following:

i´ve tried to set up my ip to on the yml file,but cant access from chrome or any other web browser either.
This is the error i get when i try to launch kibana service:

If i modify kibana to bind to port im able to access it locally with a curl ,but thats no the idea.
what im i missing? is the issue related to port permissions, ip address or yml file? any help will be greatly appreciated
The goal im trying to achieve is NOT to run kibana locally

[EDIT] Firewall is off

I can not read any of the screenshots. Please try to copy and paste text instead as it is a lot easier to read and search.

sorry :sweat_smile:
this is how i got my ip to bind kibana:

root@XXXXXX:~# curl ipinfo.io/ip

This is my yml file:

# Kibana is served by a back end server. This setting specifies the port to use.
server.port: "5601"

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: ""
# Enables you to specify a path to mount Kibana at if you are running behind a proxy. This only affects
# the URLs generated by Kibana, your proxy is expected to remove the basePath value before forwarding requests
# to Kibana. This setting cannot end in a slash.
#server.basePath: ""

# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576

# The Kibana server's name.  This is used for display purposes.
#server.name: "TerrandKibana"

# The URL of the Elasticsearch instance to use for all your queries.
#elasticsearch.url: "http://localhost:9200"

# When this setting's value is true Kibana uses the hostname specified in the server.host
# setting. When the value of this setting is false, Kibana uses the hostname of the host
# that connects to this Kibana instance.
#elasticsearch.preserveHost: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "home"

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
#elasticsearch.username: "user"
#elasticsearch.password: "pass"

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
server.ssl.enabled: true
server.ssl.certificate: /root/kibanaremote.crt
server.ssl.key: /root/kibanaremote.key

# Optional settings that provide the paths to the PEM-format SSL certificate and key files.
# These files validate that your Elasticsearch backend uses the same key files.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

# Optional setting that enables you to specify a path to the PEM file for the certificate
# authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.
elasticsearch.ssl.verificationMode: none

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
# must be a positive integer.
#elasticsearch.requestTimeout: 30000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side
# headers, set this value to [] (an empty list).
#elasticsearch.requestHeadersWhitelist: [ authorization ]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
#elasticsearch.customHeaders: {}

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 0

# Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.
#elasticsearch.startupTimeout: 5000

# Specifies the path where Kibana creates the process ID file.
#pid.file: /var/run/kibana.pid

# Enables you specify a file where Kibana stores log output.
#logging.dest: stdout

and this is the error log:

root@VMLnxPrApp01:/usr/share/kibana# sudo bin/kibana
  log   [15:12:41.719] [info][status][plugin:kibana@6.2.3] Status changed from uninitialized to green - Ready
  log   [15:12:41.808] [info][status][plugin:elasticsearch@6.2.3] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log   [15:12:42.076] [info][status][plugin:timelion@6.2.3] Status changed from uninitialized to green - Ready
  log   [15:12:42.090] [info][status][plugin:console@6.2.3] Status changed from uninitialized to green - Ready
  log   [15:12:42.102] [info][status][plugin:metrics@6.2.3] Status changed from uninitialized to green - Ready
 error  [15:12:42.139] [fatal] Error: listen EADDRNOTAVAIL 201.xxx.xxx.113:5601
    at Object.exports._errnoException (util.js:1020:11)
    at exports._exceptionWithHostPort (util.js:1043:20)
    at Server._listen2 (net.js:1249:19)
    at listen (net.js:1298:10)
    at net.js:1408:9
    at _combinedTickCallback (internal/process/next_tick.js:83:11)
    at process._tickCallback (internal/process/next_tick.js:104:9)

Is this the IP of the host Kibana is running on? Can you try with instead?

Yep, thats the host kibana, elastic, and logstash are running.

Modified the YML file to bind
Kibana started up correctly, but then when point on the browser

This site can’t be reached took too long to respond.
Search Google for 201 216 251 113 5601

I would recommend checking if you have any firewall rules that prevent access to that port. If this host is open to the internet I would however also recommend that you secure it.

firewall is off, that shouldnt be an issue right?

If you log into the host, can you telnet the port there?

telnet: Unable to connect to remote host: Connection timed out
did telnet on address and port and got that (im new to ubuntu btw sorry)

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.