Kibana issue with timeouts on reports

I have following issue,
Users are trying to perform reportts on Kibana,
Reports are performing reports, but reports are incomplete.

I tried to increase timeout and maxfilesize for reporting but this didn't solved my issue:

xpack.reporting.kibanaServer.hostname: localhost
xpack.reporting.queue.timeout: 400m
xpack.reporting.csv.maxSizeBytes: 60000000

Can someone please help me with my issue,
Is it possible also to perform report directly from elasticsearch using link ? I tried to find something but with no result.

Hello @dominbdg,

As you have increased the timeout and maxfilesize values and are now receiving incomplete reports, the problem seems to be in the content and processing of the report.

Regarding this warning message:

"Your CSV contains characters that spreadsheet applications can interpret as a formula."

Any cells, including the header, that begin with the following characters can be interpreted as a formula: =, +, -, @. In version 7.8, we had a PR that added xpack.reporting.csv.escapeFormulaValues. I am not sure which version you are using, but if it's 7.8 or later, the value already defaults to true and is escaped. Otherwise, you can try removing these characters.

Have you made any changes to other CSV settings, or are they set to their default values?

It is also important to check your query to verify that it returns the expected results or even optimize it. For example, you can run the report with a smaller date range or filter out unnecessary data and check the results.

Hope this helps!

Regarding your question about using a link, are you intending to automate report generation? If so, you can create a POST URL that triggers the generation of a CSV report.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.