Kibana LDAP authentication Realm problem


(ashok) #1

Hi,

I would like to integrate Kibana with LDAP authentication, I followed the xpack realm configuration from official documentation but its throwing following error. Can some one help me by sharing kibana.yml with working LDAP Realm configuration.

FATAL { ValidationError: child "xpack" fails because [child "security" fails because ["authc" is not allowed]]

Complete log

FATAL { ValidationError: child "xpack" fails because [child "security" fails because ["authc" is not allowed]]
at Object.exports.process (/usr/share/kibana/node_modules/joi/lib/errors.js:181:19)
at _validateWithOptions (/usr/share/kibana/node_modules/joi/lib/any.js:651:31)
at root.validate (/usr/share/kibana/node_modules/joi/lib/index.js:121:23)
at Config._commit (/usr/share/kibana/src/server/config/config.js:114:35)
at Config.set (/usr/share/kibana/src/server/config/config.js:84:10)
at Config.extendSchema (/usr/share/kibana/src/server/config/config.js:57:10)
at /usr/share/kibana/src/server/plugins/plugin_collection.js:19:12
at next (native)
at step (/usr/share/kibana/src/server/plugins/plugin_collection.js:49:191)
at /usr/share/kibana/src/server/plugins/plugin_collection.js:49:361
isJoi: true,
name: 'ValidationError',
details:
[ { message: '"authc" is not allowed',
path: 'xpack.security.authc',
type: 'object.allowUnknown',
context: [Object] } ],
_object:
{ pkg:
{ version: '5.5.0',
branch: '5.x',
buildNum: 15382,
buildSha: 'e1950ab7d0686b3a01caa0899faf4bf5a5e4904c' },
dev: { basePathProxyTarget: 5603 },
pid: { exclusive: false },
cpu: { cgroup: [Object] },
cpuacct: { cgroup: [Object] },
server:
{ name: 'kibana',
host: '0',
port: 5601,
maxPayloadBytes: 1048576,
autoListen: true,
defaultRoute: '/app/kibana',
basePath: '',
ssl: [Object],
cors: false,
xsrf: [Object] },
logging:
{ silent: false,
quiet: false,
verbose: false,
events: {},
dest: 'stdout',
filter: {},
json: true },
ops: { interval: 5000 },
plugins: { scanDirs: [Object], paths: [], initialize: true },
path: { data: '/usr/share/kibana/data' },
optimize:
{ enabled: true,
bundleFilter: '!tests',
bundleDir: '/usr/share/kibana/optimize/bundles',
viewCaching: true,
lazy: false,
lazyPort: 5602,
lazyHost: 'localhost',
lazyPrebuild: false,
lazyProxyTimeout: 300000,
useBundleCache: true,
profile: false },
status: { allowAnonymous: false, v6ApiFormat: false },
map: { manifestServiceUrl: 'https://catalogue.maps.elastic.co/v1/manifest' },
tilemap: { options: [Object] },
regionmap: {},
uiSettings: { enabled: true },
i18n: { defaultLocale: 'en' },
xpack:
{ xpack_main: [Object],
graph: [Object],
monitoring: [Object],
reporting: [Object],
security: [Object] } },
annotate: [Function] }


Clarification about LDAP Authentication
(Brandon Kobel) #2

@ashok_n the xpack.security.authc settings should be specified in your elasticsearch.yml instead of your kibana.yml.


(ashok) #3

@Brandon_Kobel Thank you very much, it worked.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.