Kibana Logs are not getting created/captured

Kibana Service Logs are not getting created/captured for both kibana.stderr and kibana.stdout

[abc@abc log]$ ll | grep kibana
drwxrwxrwx  2 kibana        kibana                48 Jan 30 13:09 kibana
[abc@abc log]$ cd kibana/
[abc@abc kibana]$ ll
total 0
-rwxrwxrwx 1 kibana kibana 0 Jan 14 09:48 kibana.stderr
-rwxrwxrwx 1 kibana kibana 0 Jan 14 09:48 kibana.stdout

Systemctl is as followed:

systemctl cat kibana.service
# /etc/systemd/system/kibana.service

# Load env vars from /etc/default/ and /etc/sysconfig/ if they exist.
# Prefixing the path with '-' makes it try to load, but if the file doesn't
# exist, it continues onward.
ExecStart=/usr/share/kibana/bin/kibana "-c /etc/kibana/kibana.yml"


Please help me with the resolution for capturing kibana.service logs.

Hey @Hazoopr. Just want to verify a few things that are easy to rule out before going further -- what's your setting (either in env vars or in kibana.yaml) for logging.dest? Also want to verify no other settings are there to squelch logging (like logging.quiet).


Hi @joelgriffith,

  1. Kibana configs are from kibana.yml sharing you the kibana.yaml file.

    #Specifies the path where Kibana creates the process ID file.
    #pid.file: /var/run/

    #Enables you specify a file where Kibana stores log output.
    logging.dest: stdout

    #Set the value of this setting to true to suppress all logging output.
    #logging.silent: false

    #Set the value of this setting to true to suppress all logging output other than error messages.
    #logging.quiet: false

    #Set the value of this setting to true to log all events, including system usage information and all requests.
    logging.verbose: false
    #logging.verbose: true

  2. I am running kibana.service via systemctl command, I know journalctl command is giving some logs but still my requirement is to capture logs in /var/log/kibana/............

Issue are solved, configuring the absolute path in the logging.dest=/var/log/kibana/kibana.stdout and it was successfully capturing the logs.

marking this as close.

Thanks for posting your solution! You beat me to it, apologies I wasn't able to get you there. Glad you've got it solved though!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.