Kibana Monitoring with Metricbeat

Hi,

I'm trying to monitor Kibana using metricbeat - pretty standard

Im having an issue where Metricbeat is getting a forbidden response from the Kibana URL. I have tested using an curl with the same credentials and it works absolutely fine.

If I run metricbeat manually with debug hoping to see why its failing, it also works fine. It appears that it only gets forbidden when running as the default installed service.

Any suggestions on what it could be or what to check? Its had me stumped now for a few hours with multiple iterations on config

Thanks

Im running Kibana and metricbeat on 7.13.2

Could you please provide more details? Metricbeat configuration? Kibana URL? Did you try to enable debug mode in metricbeat?

HI @mtojek - Yes, as advised above I ran metricbeat with debug and it connected to Kibana fine with my configuration and provided my cluster the stats and status from Kibana, but when running on the default installed service it gets the forbidden error.