Kibana not able to connect to elasticsearch


I am not able to connect to my elasticsearch instance from kibana instance. Both are on AWS EC2.
Getting this error:

Error: Unknown error while connecting to Elasticsearch
Error: Internal Server Error
at respond (
at checkRespForFailure (
at wrappedErrback (
at wrappedErrback (
at wrappedErrback (
at Scope.$eval (
at Scope.$digest (
at Scope.$apply (

My kibana.yml

port: 5601
host: ""
elasticsearch_url: "10.0.30.yyy:9200"
elasticsearch_preserve_host: true
kibana_index: ".kibana"
default_app_id: "discover"
ping_timeout: 15000
request_timeout: 900000
shard_timeout: 0

any help?

Can you connect to ES ok - curl IP:9200?

Anyway I solved the problem. Not exactly solved it but downgraded the version of kibana and it worked like a charm. 4.1.2->4.1.1

I guess its a bug in Kibana latest version.

Unlikely, otherwise I'd have the same problem :wink:

If its working for you then it should work for me too. It cannot be connection problem as firewall is off on both the machines and the both belong to the same subnet. In my post I have mentioned my config file. Is something wrong with it?

Looks ok from what I can see.