Kibana not loading bcas of allow_explicit_index is disabled


(jigish thakar) #1

We are using ES 2.3 with below setting

rest.action.multi.allow_explicit_index: false

and due to some business logic, we cant enable above setting.
we need Kibana 4, to work on this cluster and its giving below error.

Courier Fetch Error: unhandled courier request error: [illegal_argument_exception] explicit index in multi get is not allowed

how to make kibana4 working without changing anything on cluster?
any help is appreciated.


(Joe Fleming) #2

Nearly all requests that Kibana makes are _bulk requests, and they always specify the index in the body, so Kibana is not going to work at all with that Elasticsearch configuration.

Your best bet is to operate without that setting. The only option I can think of is writing a custom proxy of some kind that would take the request, read the index out of the body and re-write the request passing it via the URL instead (and setting the body's index to {}). You might also be able to modify the proxy code in Kibana to do this, but there's no way to do it without writing some code.

I'm curious though, why is that setting necessary? Can you provide any insight?


(jigish thakar) #3

Thanks for the reply Joe.
Issue is, we have implemented ACL on the basis of request URL, and we are not using Sheild.
so this setting is essential for us.
I will have rethink whole approach now.

appreciate your reply :slight_smile:


(jigish thakar) #4

Found solution to this.
we launched one more client node, and enabled allow_explicit_index. and it worked like charm :slight_smile:


(Mohankumar K H) #5

Hi,

What is the solution you have implemented can you explain me in details. I would like to replicate the same.


(jigish thakar) #6

Hey sorry for late reply.
we added one more client node and kept below setting in elasticsearch.yml

rest.action.multi.allow_explicit_index: true

and it worked


(system) #7