Kibana port not work property

Is anyone else having trouble accessing Kibana in the browser either via port 5601 or via 80 with authentication via NGINX?

My scenery:
O.S: Ubuntu Server Minimal 18.04 - LTS
Firewall: UFW disable
I made the entire installation via repository, following some tests:

mservice@sentinel:~$ sudo ufw status
[sudo] password for mservice:
Status: inactive
mservice@sentinel:~$ curl -v
* Rebuilt URL to:
*   Trying
* connect to port 5601 failed: Connection refused
* Failed to connect to port 5601: Connection refused
* Closing connection 0
curl: (7) Failed to connect to port 5601: Connection refused
mservice@sentinel:~$ sudo systemctl status kibana
● kibana.service - Kibana
   Loaded: loaded (/etc/systemd/system/kibana.service; disabled; vendor preset: enabled)
   Active: active (running) since Wed 2018-08-08 09:20:20 -03; 51s ago
 Main PID: 19392 (node)
    Tasks: 10 (limit: 4648)
   CGroup: /system.slice/kibana.service
           └─19392 /usr/share/kibana/bin/../node/bin/node --no-warnings /usr/share/kibana/bin/../src/cli -c /etc/kibana/kibana.yml

Aug 08 09:20:20 sentinel systemd[1]: Started Kibana.

When access via browser return error 501 - bad gateway

What does your NGinx proxy look like?

1 Like

@tylersmalley, I wrote it:

server {
        listen 80;

        server_name sentinela;

        auth_basic "Acesso Restrito!";
        auth_basic_user_file /etc/nginx/htpasswd.kibana;

        location / {
            proxy_http_version 1.1;
            proxy_set_header Upgrade $http_upgrade;
            proxy_set_header Connection 'upgrade';
            proxy_set_header Host $host;
            proxy_cache_bypass $http_upgrade;        

I'm not familiarity with NGinx.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.