Kibana server.publicBaseUrl

image

I am seeing this error on my Kibana

I have several questions

  1. Where do I configure that setting?
  • in kibana.yml ?
  • in Elasticsearch.yml ?
  1. What should I set the setting to?

Kibana.yml

# File managed by Puppet.
---
elasticsearch.hosts:
- https://es01.sanitized:9200
- https://es02.sanitized:9200
- https://es03.sanitized:9200
- https://es04.sanitized:9200
- https://es05.sanitized:9200
elasticsearch.password: sanitized
elasticsearch.ssl.certificateAuthorities:
- "/etc/pki/ca-trust/source/anchors/sanitized.crt"
elasticsearch.username: sanitized
logging.dest: "/var/log/kibana/kibana.log"
server.port: 5601
xpack.actions.preconfiguredAlertHistoryEsIndex: true
xpack.encryptedSavedObjects.encryptionKey: sanitized
xpack.security.audit.enabled: true
xpack.security.enabled: true
xpack.security.secureCookies: true
xpack.xpack_main.telemetry.enabled: false

Elasticsearch.yml

### MANAGED BY PUPPET ###
---
bootstrap.memory_lock: false
discovery.seed_hosts:
- es01.sanitized
- es02.sanitized
- es03.sanitized
- es04.sanitized
- es05.sanitized
http.port: 9200
network.host:
- _site_
- _local_
path.data: "/srv/elasticsearch"
path.logs: "/var/log/elasticsearch"
transport.port: 9300
xpack.monitoring.collection.enabled: true
xpack.security.audit.enabled: true
xpack.security.audit.logfile.events.emit_request_body: true
xpack.security.audit.logfile.events.ignore_filters:
  system_users:
    users:
    - system_*
    - _system
    - _xpack_security
xpack.security.audit.logfile.events.include:
- authentication_failed
- authentication_success
- access_granted
- access_denied
- tampered_request
- connection_denied
xpack.security.authc.realms.file.dap.order: 0
xpack.security.authc.realms.ldap.dap389.bind_dn: sanitized
xpack.security.authc.realms.ldap.dap389.files.role_mapping: "/etc/elasticsearch/role_mapping.yml"
xpack.security.authc.realms.ldap.dap389.order: 1
xpack.security.authc.realms.ldap.dap389.ssl.truststore.path: "/etc/elasticsearch/truststore.jks"
xpack.security.authc.realms.ldap.dap389.url: ldaps://sanitized,ldaps://sanitized
xpack.security.authc.realms.ldap.dap389.user_search.base_dn: sanitized
xpack.security.authc.token.enabled: true
xpack.security.enabled: true
xpack.security.http.ssl.enabled: true
xpack.security.http.ssl.keystore.path: "/etc/elasticsearch/elasticsearch.jks"
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.keystore.path: "/etc/elasticsearch/elasticsearch.jks"
xpack.security.transport.ssl.truststore.path: "/etc/elasticsearch/truststore.jks"
xpack.security.transport.ssl.verification_mode: certificate

Official Documentation: Configure Kibana | Kibana Guide [7.16] | Elastic

We access Kibana via https://kibana7.sanitized/app/home#/

Also, which features are not behaving correctly?

kibana.yml. for example

server.publicBaseUrl: http://your_systemname:5601

1 Like

So like in kibana.yml

server.publicBaseUrl: https://kibana7.sanitized.dk:5601

It works in our test environment. Thanks a lot.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.