Kibana server unable to connect to :5601

This is my kibana.yml

# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "0.0.0.0"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false

# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576

# The Kibana server's name.  This is used for display purposes.
#server.name: "your-hostname"

# The URLs of the Elasticsearch instances to use for all your queries.
elasticsearch.hosts: ["192.168.188.134:9200"]

# When this setting's value is true Kibana uses the hostname specified in the server.host
# setting. When the value of this setting is false, Kibana uses the hostname of the host
# that connects to this Kibana instance.
#elasticsearch.preserveHost: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "home"

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
#elasticsearch.username: "kibana"
#elasticsearch.password: "pass"

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

# Optional settings that provide the paths to the PEM-format SSL certificate and key files.
# These files are used to verify the identity of Kibana to Elasticsearch and are required when
# xpack.security.http.ssl.client_authentication in Elasticsearch is set to required.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

# Optional setting that enables you to specify a path to the PEM file for the certificate
# authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.
elasticsearch.ssl.verificationMode: none

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
# must be a positive integer.
#elasticsearch.requestTimeout: 30000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side
# headers, set this value to [] (an empty list).
#elasticsearch.requestHeadersWhitelist: [ authorization ]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
#elasticsearch.customHeaders: {}

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 30000

# Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.
#elasticsearch.startupTimeout: 5000

# Logs queries sent to Elasticsearch. Requires logging.verbose set to true.
#elasticsearch.logQueries: false

# Specifies the path where Kibana creates the process ID file.
#pid.file: /var/run/kibana.pid

# Enables you specify a file where Kibana stores log output.
#logging.dest: stdout

# Set the value of this setting to true to suppress all logging output.
#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.
#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information
# and all requests.
#logging.verbose: false

# Set the interval in milliseconds to sample system and process performance
# metrics. Minimum is 100ms. Defaults to 5000.
#ops.interval: 5000

# Specifies locale to be used for all localizable strings, dates and number formats.
# Supported languages are the following: English - en , by default , Chinese - zh-CN .
#i18n.locale: "en"

this is what happens when i restart and check the status of kibana

[root@localhost kibana]# systemctl status kibana.service -l
● kibana.service - Kibana
   Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)
   Active: active (running) since Sun 2022-05-08 04:21:54 PDT; 1s ago
 Main PID: 68694 (node)
    Tasks: 7
   CGroup: /system.slice/kibana.service
           └─68694 /usr/share/kibana/bin/../node/bin/node /usr/share/kibana/bin/../src/cli -c /etc/kibana/kibana.yml

May 08 04:21:54 localhost.localdomain systemd[1]: Started Kibana.
[root@localhost kibana]# systemctl status kibana.service -l
● kibana.service - Kibana
   Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)
   Active: active (running) since Sun 2022-05-08 04:21:54 PDT; 4s ago
 Main PID: 68694 (node)
    Tasks: 11
   CGroup: /system.slice/kibana.service
           └─68694 /usr/share/kibana/bin/../node/bin/node /usr/share/kibana/bin/../src/cli -c /etc/kibana/kibana.yml

May 08 04:21:54 localhost.localdomain systemd[1]: Started Kibana.
May 08 04:21:57 localhost.localdomain kibana[68694]: {"type":"log","@timestamp":"2022-05-08T11:21:57Z","tags":["warning","plugins-discovery"],"pid":68694,"message":"Expect plugin \"id\" in camelCase, but found: apm_oss"}
May 08 04:21:57 localhost.localdomain kibana[68694]: {"type":"log","@timestamp":"2022-05-08T11:21:57Z","tags":["warning","plugins-discovery"],"pid":68694,"message":"Expect plugin \"id\" in camelCase, but found: file_upload"}
May 08 04:21:57 localhost.localdomain kibana[68694]: {"type":"log","@timestamp":"2022-05-08T11:21:57Z","tags":["warning","plugins-discovery"],"pid":68694,"message":"Expect plugin \"id\" in camelCase, but found: triggers_actions_ui"}
[root@localhost kibana]# systemctl status kibana.service -l
● kibana.service - Kibana
   Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)
   Active: activating (auto-restart) (Result: exit-code) since Sun 2022-05-08 04:22:03 PDT; 435ms ago
  Process: 68694 ExecStart=/usr/share/kibana/bin/kibana -c /etc/kibana/kibana.yml (code=exited, status=1/FAILURE)
 Main PID: 68694 (code=exited, status=1/FAILURE)

May 08 04:22:03 localhost.localdomain systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE
May 08 04:22:03 localhost.localdomain systemd[1]: Unit kibana.service entered failed state.
May 08 04:22:03 localhost.localdomain systemd[1]: kibana.service failed.

Hi @Heythem_DHAOUADI If you enabled https on Elasticsearch I think that should be

elasticsearch.hosts: ["https://192.168.188.134:9200"]

Did you enable authentication? if you you will need to also add the Elasticsearch username and password.

You should also look at the actual kibana logs to see more detail... not just systemctl status you might need to enable logging to that if this does not work... or use journalctl

1 Like

i added http:// and it works now Elasticsearch.hosts: ["http://192.168.188.134:9200"],
but i have another problem after that if anyone can help me with ,
so after running the command for adding agents to wazuh
sudo WAZUH_MANAGER='192.168.188.134' yum install https://packages.wazuh.com/3.x/yum/wazuh-agent-3.12.3-1.x86_64.rpm
nothing is added on the wazuh server , it does not detect the new agent .

Hi @Heythem_DHAOUADI Good to hear.

With respect to your additional question I would open a new thread ... I will say you should probably visit the wazuh community for that though as this forum is dedicated to the Elastic Stack ... which wazuh is not part of... even though lots of folks ship their wazuh data to Elasticsearch... so you might get some help here ... or not :slight_smile:

1 Like

thank's alot for your help

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.