Kibana service not running

Hi there,

I recently had our IT build me a new computer that I am dedicating for a simple elasticsearch/kibana machine. I had previously built my own machine for the same purpose and was successful, that machine was running version 7.9.1-1 of both Kibana and Elasticsearch.
On this new machine I used the repo files which specify "7.x" and it's installed version 7.10.2-1 of both elasticsearch and kibana.

The installation seems to go fine but when I run
sudo service -i kibana start
I get:
[centos@kibana ~]$ sudo -i service kibana start
Starting kibana (via systemctl): [ OK ]
But then when I run:
sudo service --status-all
I see:
kibana is not running

But the service does seem to be actively running and I can reach it through the browser on the proper port.
And when I run:
[centos@kibana ~]$ sudo systemctl status kibana.service
It appears to be running:
● kibana.service - Kibana
Loaded: loaded (/etc/systemd/system/kibana.service; disabled; vendor preset: disabled)
Active: active (running) since Fri 2021-02-05 21:06:28 UTC; 21min ago
Main PID: 1368 (node)
CGroup: /system.slice/kibana.service
└─1368 /usr/share/kibana/bin/../node/bin/node/usr/share/kibana/bin/../src/cli/dist

There is also no directory ever created for the logs (/var/logs/kibana/), but there is one for elasticsearch.
Has anyone experienced this before or have any idea what's going on exactly?
Thank you!

Did you build the packages yourself from source? Since 7.10.2 is released I would suggest just using the artifacts available here: Kibana 7.10.2 | Elastic

I installed the packages using repo files and instructions from these webpages:

I had some of my IT coworkers take a look at the issue and they've said there was:

The issue with the lack of logging in /var/log/kibana & service --status-all saying kibana wasn't running was due to a collision between systemd & sysV where a pid file was not being produced.

And that,

Multiple scripts were stepping on each other with regard to the pid file.

This wasn't an issue in 7.9 because etc/init.d/kibana changed between versions.

They were able to comment out some lines in etc/init.d/kibana and remove the systemd files/functionality for kibana & elasticsearch, so now it works with service, properly shows it's running with service --status-all and produces log files in /var/log/kibana like it should.