Kibana Setting "logging.dest" is deprecated can't be fixed

Hi all,

We are facing an issue with Kibana 7.16.0 on Ubuntu 18.04. In Kibana log I can see a warning message ["warning","config","deprecation"],"pid":24471,"message":""logging.dest" has been deprecated and will be removed in 8.0. To set the destination moving forward, you can use the "console" appender in your logging configuration or define a custom one."}.

In the upgrade assistant for ELK 8.0 we are facing the same message. To correct it seems we have to add this parameters :

logging:
  appenders:
    file:
      type: file
      fileName: /var/log/kibana.log
      layout:
        type: pattern
  loggers:
    - name: plugins.myPlugin
      appenders: [file]

I'm starting with ELK and I don't know how to add this parameters, I try with a cURL but this does not solve the problem. In kibana.yml I removed logging.dest like this is mentionned in the picture.

logging.dest

Could someone can help me to resolve this issue ?

Thanks for your answer.

Hi, got the same problem. All changes in kibana.yml are ignored. I noticed that "logging.dest" is hardcoded in unit file "kibana.service".
So what to do about that?
Thanks

Hi all,

Upgrading to 7.16.2 did not solve the problem.

I added the parameters to kibana.yml but the critical warning is still present in Kibana UI

Yes and I don't know if we have to pass this parameters in Kibana Console or with a cURL command.

You have to add it to the /etc/kibana/kibana.yml file.

I noticed the default appender is required:

Jan 13 10:30:14 stvjustxelk001 kibana[7812]: FATAL Error: [config validation of [logging].root]: "default" appender required for migration period till the
next major release

My config:

# Enables you to specify a file where Kibana stores log output.
#logging.dest: stdout
#DEPRECATED
#logging.dest: /var/data/log/kibana/kibana.log

# Set the value of this setting to true to suppress all logging output.
#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.
#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information
# and all requests.
#logging.verbose: false
#logging.verbose: true


logging:
  appenders:
    file:
      type: file
      fileName: /var/data/log/kibana/kibana.log
      layout:
        type: pattern
  root:
    appenders: [default,file]

Documentation mentions the properties:

If you are using the debian/rpm packages you can ignore this deprecation warning. Starting in 7.17 this deprecation warning will no longer show on these platforms [7.17] [deb/rpm] Skip deprecation warning for logging.dest by jbudz · Pull Request #120273 · elastic/kibana · GitHub When upgrading to 8.0 Kibana the new package will correctly configure the new logging format, so no action is required.

Hi,

I tried this and that's not working. I also upgrade to 7.16.3 and problem is still here.

Hi,

Okay I'm waiting for the 7.17 to be release to see if this solve the issu.

Hi,

Upgrading to 7.17 fix the issue.

2 Likes

Upgrading to 7.17.0 didn't fix the issue for me

Upgrading to 8.0.0 didn't fix the issue

I had to backup my config and apt purge kibana

Once I reinstalled and put back the config it was fine

(the kibana unit file still had the --logging.dest set)

2 Likes

Looks like that was probably caused by Kibana 7 having its service in /etc/systemd/system/kibana.service but Kibana 8 has it in /usr/lib/systemd/system/kibana.service and it does not look like upgrading deletes the old one, so both end up being there and the one in /etc has the priority.

I had to do the following to get Kibana back up and running:

mv /etc/systemd/system/kibana.service /etc/systemd/system/kibana.service.disabled
systemctl daemon-reload && systemctl restart kibana
6 Likes

Yes, in 7.17 the warning message disapear but when upgrading to 8.0 i could not restart Kibana, I did the same step like you and that's fix the problem. It seems ELK Team just remove the warning message but didn't fix the issue for the upgrade.

Glad it worked.

@C0rn3j I tried to disable the service but I don't think it was enough.

systemctl disable kibana

I have another server to upgrade so I'll try it one more time just to be sure.

So many changes lately, it's hard to keep track, ECS, composable index templates, fleet

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.