Kibana stats panel


(Jeff Klug) #1

The stats panel doesn't seem to work for me at all. I want it to calculate
the mean of a numeric field, but it just prints out 0. No errors.

Anybody got this working?

JK

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/28062345-6dbf-42f5-94af-bb67daabc687%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Binh Ly-2) #2

By any chance, is it possible that in the mapping, the field is not numeric
(like maybe a string)?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/715bedf8-043d-4a4e-8f49-7e03cdef1398%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jeff Klug) #3

using logstash grok, match pulls the field as %{BASE16FLOAT:avgt}

json pulled by kibana:

{
"_index": "logstash-2014.03.27",
"_type": "jobended",
"_id": "mn8h50n8SF693JLDZdBx8A",
"_source": {
...
"avgt": "1.75",
...
}
}

trying to get stats to find mean of avgt

JK

On Fri, Mar 28, 2014 at 10:49 AM, Binh Ly binhly_es@yahoo.com wrote:

By any chance, is it possible that in the mapping, the field is not
numeric (like maybe a string)?

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/gOG7T5-Hcag/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/715bedf8-043d-4a4e-8f49-7e03cdef1398%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/715bedf8-043d-4a4e-8f49-7e03cdef1398%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAJ33_N-BvB_dcB%2BT%2B9bGw2jxZ4LxBPyzpfk%3DjZ1wLXy%3D2QL7XA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Binh Ly-2) #4

Yup, you probably need to convert the type of that field:

http://logstash.net/docs/1.4.0/filters/mutate#convert

mutate convert it to float and try it again.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e49fa51a-0263-4f29-846b-f72bd634e03e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jeff Klug) #5

yup. mutated and working now. Thanks!

On Fri, Mar 28, 2014 at 12:11 PM, Binh Ly binhly_es@yahoo.com wrote:

Yup, you probably need to convert the type of that field:

http://logstash.net/docs/1.4.0/filters/mutate#convert

mutate convert it to float and try it again.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/gOG7T5-Hcag/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/e49fa51a-0263-4f29-846b-f72bd634e03e%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/e49fa51a-0263-4f29-846b-f72bd634e03e%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAJ33_N_Bf74kJQnrF0QaRMVgEpddA4is4EqrMTWiDnR3RoMk_g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #6