Kibana taking time to load discover

I have around 6 GB of data coming to elastic search per day.
The problem is that it takes around 5-6 seconds to load discover or conduct any search. I was trying to tune - to make it faster.

I have the following observations :

  1. I have enabled the default shard and replica allocation. That is , 5 shards and 1 replica per index. But because I am using one node , the replica is not assigned and hence health of the index is yellow. I can also see that i have 5 unassigned shards. Can this slow down the discover ? The shards are already unassigned , how can it consume resource ?

  2. I don't want to disable the highlight of search.

  3. Also the default discover:sampleSize has been reduced to just 100.

  4. I have around 83 saved searches.

Hi @mrashid,
have you took a look at this: this will for sure help you on tuning your elasticsearch together with

Thanks @markov00 for responding back.

I have done most of the things mentioned already. I have increased the jvm heap to 30Gb from the default of 1 Gb for elastic search (as can be seen in the above scrrenshot). Have got around 15 fields only. If the shards have been unassigned , I dont need to worry that the extra shards are consuming more resources , I guess .

I have a field which I am sorting for each search query . I suspect this is taking up the time. Let me pre-index and sort it through template as mentioned one of the article. I will update here .

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.