Kibana Timelion doesn't use proxy when connecting to Quandl


(Drew Town) #1

We are behind a corporate proxy for all outgoing requests on 80 and 443. When using Timelion v5.0.0 and requesting data from Quandl we get a failure.

    Timelion: Error:  in cell #3: request to [quandl url] failed, reason: connect ECONNREFUSED 54.174.87.84:443

Is there a configuration I am missing in order to get Timelion to utilize a proxy either via configuration or environment variable?


(Tim Sullivan) #2

This could be happening because requests for data Timelion that makes come from the Kibana server, not the browser. Having a firewall between the Kibana server and the outside Internet is likely the problem.


(Drew Town) #3

I do have http_proxy and https_proxy environment variables setup on the kibana server. It doesn't seem to utilize those variables though.


(Tim Sullivan) #4

As far as I can tell, software has to be designed to be aware of that variable, and many Ubuntu utilities are, such as apt-get. But it looks like NodeJS isn't aware of that env. variable and it doesn't come with its own way to configure proxy settings globally.

I have seen in some coding forums that people have decided to overwrite the http.request method in Node to get it to include global proxy settings. You are free to file an issue in https://github.com/elastic/kibana/issues and give the team a proposition for implementing a solution for this use case.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.