Kibana unable to see stored field "_size"?


(Ajinkya) #1

Hi All,

I have an elasticsearch cluster with around 4Bn docs. I am trying to do some analysis to get insights in our document sizes. For this I am using the mapper-size plugin to enable the "_size" field. Now after i build the es indices, i am seeing this field under "stored_fields". However for some reason kibana doesn't pick this field by default (atleast not that i know of). Is there a way to enable this field in kibana ? I know stored_fields are hidden, so i just want a way expose it to kibana so as to make my analysis.

Thanks for your help in advance.

Edit : ES v 5.4.3
KIbana V 5.4.3


(Brandon Kobel) #2

Hey @AJinkya if you go to Management -> Advanced Settings, you can add _size to the metaFields setting, you'll then want to refresh your index pattern by going to Management -> Index Patterns and clicking the "Refresh" button for the appropriate index pattern.

You should now see the _size field now.


(Ajinkya) #3

Hi @Brandon_Kobel Thanks a lot. That helped.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.