Kibana updated, now it will only show it's not ready, what do I do?

Hey guys,

I didn't know we had Elastic Search/Kibana yum repo configured, I ran a yum -y update and it updated it, after that when I tun systemctl status kibana it shows as running, but the URL will only give me a page saying it's not ready yet and I don't see a log for kibana in /var/log/kibana, any ideas what could have happened here and how can I fix it?


Hey @Jorge_Hernandez,

Is the journalctl showing any output? What version were you running before you ran the update, and what version were you updated to? How long has it been stuck in this state?

This is what journalctl shows:

Mar 17 15:08:44 mot-elk kibana[7432]: {"type":"log","@timestamp":"2020-03-17T19:08:44Z","tags":["warning","savedobjects-service"],"pid":7432,"message":"Unable to connect to Elasticsearch. Error: [resource_already_exists_exception] index [.kibana_task_manager_2/HWz0LruBSkSCw0StyyHksA] already exists, with { index_uuid=\"HWz0LruBSkSCw0StyyHksA\" & index=\".kibana_task_manager_2\" }"}

Mar 17 15:08:44 mot-elk kibana[7432]: {"type":"log","@timestamp":"2020-03-17T19:08:44Z","tags":["warning","savedobjects-service"],"pid":7432,"message":"Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana_task_manager_2 and restarting Kibana."}

As per the version I'm not sure what we had before, but it might have been 6.x

It has been like this since yesterday.

Try deleting the .kibana_task_manager_2 index from Elasticsearch, and restarting Kibana. Don't worry, this shouldn't cause any data loss.

Where is this file located?, I just searched for it in / and did not get any results.

It's an index, so there won't be a corresponding file for you to delete. Instead, issue this command to Elasticsearch:

curl -X DELETE http://localhost:9200/.kibana_task_manager_2

You may need to provide credentials, in which case, do so using the -u flag:

curl -X DELETE http://localhost:9200/.kibana_task_manager_2 -u elastic:changeme


I just did that, restarted kibana, but it still shows the same thing.

This is what I saw when I ran the command (using username and password):


Never mind, it asked to delete .kibana_task_manager_1, so I did the same for this file and it's working again.

Thanks for your help.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.