[Kibana/Vega] "inveted" EMS vector maps in Vega

Hi,

I'm trying to use EMS vector maps in Vega.
I manage to retrieve the data and map it with the following bits of code:

[...]
{name:"franceDept" 
   url:{
      %type%:"emsfile"
      name:"France Departments"
   }
   format:{property:"features",feature:"geometry"}	
}

[...]

marks:[
    {
       type:"shape"
       "from":{"data":"dataDept"}
          "encode":{
             "update":{
                "strokeWidth":{"value":0.5}
                "stroke":{"value":"#000000"}
             }
             "hover":{"strokeWidth": {"value": 100},
                "stroke": {"value": "red"},
                "zindex": {"value": 1}
              }
          }
          "transform":[
             {"type":"geoshape","projection":"projection"}
          ]
   }
]

But when I try to fill each individual shape with a color, it seems that it's the outside of the shape that's filled.

Found this post here which points to a winding order problem.

Is there a way to solve this?
Tried modifyng the coordinates array of the dataset with the reverse expression, but no luck...

Thanks.

Regards.

What version of Kibana are you using? Have you tried using Maps?

Hi,

Sorry forgot that.
We're using Kibana 7.13.2.

Yes, we're using Maps. But also Vega for more specific visualizations that we couldn't manage with Maps.

I'm trying to find ways in Vega to get around a zoom level bug that I reported previously (here).

Would be much easier if I could install a third-party Tile Map Service or have access to topojson files outside of Kibana until the bug is corrected, but our IT is not very responsive for this kind of things.
And our next Kibana upgrade will be here in quite a long time...

So I'm trying to use vector maps from the EMS and not the base map ( mapStyle: true) to have normal zoom levels.

Regards,

Try setting fill to color the interior of shapes.

That's what I did.
Thing is it colors the area outside of the shape...