Kibana visual shows wrong value

Hi,
I've made a stacked bar chart as shown below.
suspected duplicates
When I hovered on the particular stack it has shown the count is 8. But when I clicked on the same stack, it has shown the count is 10. See below the reference image.
suspected duplicates2
I took 1-day data for the visualisation.
Actually the second image shows the correct data i.e. 10. But in the first image its showing wrong value i.e. 8.
Why does this thing happen? Why it shows 8 instead of 10?
Please help!

Can you take a look into the queries kibana is doing in each case? You need to open the Inspect link in the visualization top bar and check both tabs for the Request and Response. You can actually copy the request into the Kibana Dev Console adding a GET /your_index/_search to execute the query on your own.

I'm thinking you may be hitting something similar to this scenario where time zone settings could affect the results, but for sure checking the queries and results will give a pointer on why Kibana is giving different results.

Hope it helps!!

Hi Jorge,
Thanks for your response. My Kibana's timezone is in UTC and my server timezone is also in UTC. Please find the reference image below.


I've read the link you provided. I feel, for them, this is the issue. One more thing need to clarify is, their x-axis has timestamp where my x axis has terms. If it helps to detect the issue.
Please help!

One more thing need to clarify is, their x-axis has timestamp where my x axis has terms. If it helps to detect the issue.
Please help!

This is a different issue, could you please open a new forum discussion about that topic with full details? I'm afraid I won't be of much help and closing this an opening a new post will bring this to other colleagues attention.

Thanks, Jorge for your response. I've posted the same including those points. Below is the link of that post.

Hope to get a solution soon.. :slight_smile: