Kibana won't recognise a field as a date


I have a CSV file with a field called posted_at which takes date and time values, formatted like this: 01/01/2019 12:34:56.

I have been uploading this CSV to Kibana with the intention of creating visualisations, including a date histogram, but posted_at is always given the "keyword" type, rather than the "date" type.

I have tried:

  • Overriding the settings in the summary page before importing.
  • Editing the mappings to give posted_at the "date" type before importing.
  • Changing the date format under advanced settings after importing.
  • Formatting the date differently in the original CSV and re-importing.
  • Reading through previous similar threads and trying those solutions.

Nothing has worked - posted_at is given the "keyword" type no matter what I try.

How can I rectify this? Is there a specific format I need to have in the CSV for the field to be recognised as a date?

Thanks in advance.


To anyone with the same problem in the future - change the date format in your CSV to 2019-01-01 00:00:00.

I did this and then Kibana immediately recognised the field as a date.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.