Knapsack 0.90.3

Hello,

after upgrading ES to 0.90.3 knapsack stopped working for me, it gives an
10bytes archive (empty archive)
I tried an remove of the plugin and an install afterwards, but no luck.

Is this a known problem? any solution yet :slight_smile:

Also Tried:
http://dl.bintray.com/hmalphettes/elasticsearch-custom-headers/org/xbib/elasticsearch/plugin/elasticsearch-knapsack/2.0.0.1s/

Same problem archive becomes 10bytes (empty)

Elasticsearch log file does not say much:
after command:
curl -XPOST
'localhost:9200/com-2013.08.24/_export?target=/media/ephemeral0/elasticsearch/archive2.tar.gz'

[2013-08-29 06:58:06,907][INFO
][org.xbib.elasticsearch.action.RestExportAction] [Anti-Cap] cluster
'yellow' check before exporting to
/media/ephemeral0/elasticsearch/archive2.tar.gz
[2013-08-29 06:58:06,910][INFO
][org.xbib.elasticsearch.action.RestExportAction] [Anti-Cap] starting
export to /media/ephemeral0/elasticsearch/archive2.tar.gz

Thanks,
Jasper

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Sorry for the inconvenience. I have to update the plugin. It seems it does
not work with 0.90.3

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks for your very quick confirmation!!
Do you already have an idea where it goes wrong?

Thanks,
Jasper

Op donderdag 29 augustus 2013 09:10:21 UTC+2 schreef Jörg Prante:

Sorry for the inconvenience. I have to update the plugin. It seems it does
not work with 0.90.3

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Yes, API change in 0.90.3 :frowning:

Jörg

[2013-08-29 09:35:55,172][INFO
][org.xbib.elasticsearch.action.RestExportAction] [Wind Warrior] starting
export to /tmp/archive.tar.gz
Exception in thread "elasticsearch[Wind Warrior][Knapsack export
[test]][T#1]" java.lang.NoSuchMethodError:
org.elasticsearch.cluster.metadata.MetaData.indices()Lorg/elasticsearch/common/collect/ImmutableMap;
at
org.xbib.elasticsearch.action.RestExportAction.getSettings(RestExportAction.java:201)
at
org.xbib.elasticsearch.action.RestExportAction.access$500(RestExportAction.java:66)
at
org.xbib.elasticsearch.action.RestExportAction$1.run(RestExportAction.java:135)
at java.lang.Thread.run(Thread.java:680)

On Thu, Aug 29, 2013 at 9:16 AM, Jasper Geurtsen jasper@9apps.net wrote:

Thanks for your very quick confirmation!!
Do you already have an idea where it goes wrong?

Thanks,
Jasper

Op donderdag 29 augustus 2013 09:10:21 UTC+2 schreef Jörg Prante:

Sorry for the inconvenience. I have to update the plugin. It seems it
does not work with 0.90.3

Jörg

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Can you check if new released 2.0.1 works? I fixed the API change, it works
for me again. Thanks for reporting.

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks Jörg for fixing this so fast!!

Just tested it and it works :slight_smile:

Thanks,
Jasper

Op donderdag 29 augustus 2013 10:05:03 UTC+2 schreef Jörg Prante:

Can you check if new released 2.0.1 works? I fixed the API change, it
works for me again. Thanks for reporting.

https://github.com/jprante/elasticsearch-knapsack

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.