Kuromojiのプラグインがインストールできませんでした。


(HG) #1

elasticsearch 2.1.0を使用しております。

kuromojiのプラグインをインストールしようとしたところ以下のようなエラーがでます。
ググっても解決策が見つからなかったため質問させて頂きます。

$ plugin install elasticsearch/elasticsearch-analysis-kuromoji/

Verifying https://github.com/elasticsearch/elasticsearch-analysis-kuromoji/archive/master.zip checksums if available ...
NOTE: Unable to verify checksum for downloaded plugin (unable to find .sha1 or .md5 file to verify)
ERROR: Could not find plugin descriptor 'plugin-descriptor.properties' in plugin zip

宜しくお願いします。


(Jun Ohtani) #2

2.0から、主要なプラグインのインストール方法が変更されています。
https://www.elastic.co/guide/en/elasticsearch/plugins/current/installation.html

Kuromojiのインストール方法はこちらになります。
https://www.elastic.co/guide/en/elasticsearch/plugins/current/analysis-kuromoji.html


(HG) #3

ご回答ありがとうございます。
公式の方法で試したのですが、ダメでした。

$ sudo bin/plugin install analysis-kuromoji
sudo: bin/plugin: command not found

$ sudo /usr/local/bin/plugin install analysis-kuromoji
でやると、質問文のエラーが表示されます。

$ where elasticsearch
/usr/local/bin/elasticsearch


(Jun Ohtani) #4

sudoなしでやってみてもらえますか?

環境次第なので、こちらも参考にしていただければ。
https://www.elastic.co/guide/en/elasticsearch/plugins/current/plugin-management.html


(HG) #5

sudoなしで試しましたが、同様にダメでした。

/usr/local/bin/plugin -h
でも見てましたが、解決できそうにないので、もう少し、調べてみようと思います・・・。


(HG) #6

ちなみに、
以前同じPCではkuromojiプラグインはインストールできました。

brew uninstall elasticsearch をしたうえで、brew install elasticsearch をし、その後から調子が悪いです。


(Jun Ohtani) #7

ディレクトリの権限などの問題があるような気がします。
brewでインストールされる、ディレクトリの所有者などを調べてみてはどうでしょうか。


(HG) #8

個人用PCで自分以外のユーザーは使用していません。

おかしいなと思って調べていると
Mac用アンチウィルスソフトが関係するのではないかと思っております。

avastのセキュリティソフト(無料版)を使用してますが、それが悪さをしてるのかもしれません・・・。


(system) #9