License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster


(Zelfapp) #1

Today, on my localhost dev I upgraded from ES and Kibana 6.1.2 to 6.3.2.

The upgrade has all gone smoothly except for kibana. In my kibana.yml you can see that I'm connecting to a remove url. This worked great in kibana 6.1.2. A password dialog would popup. What has changed in 6.3.2? I've tried the "xpack.security.enabled: false" I've seen in the discussions, but my remote host with my ES instance requires a user/password and it just keeps giving me the same error in the logs anyway with or without it. I'm not seeing the solution to this in the docs. Again, this is on my localhost dev system and I'm connecting to a remote host.

server.name: production_kibana
server.host: "esproduction"
server.port: 5699
elasticsearch.url: "myremoteurl:port"
elasticsearch.username: "user"
elasticsearch.password: "mypassword"

Error logs:

log [23:04:53.976] [warning][license][xpack] License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [invalid_index_name_exception] Invalid index name [xpack], must not start with ''., with { index_uuid="na" & index="_xpack" } :: {"path":"/_xpack","statusCode":400,"response":"{"error":{"root_cause":[{"type":"invalid_index_name_exception","reason":"Invalid index name [xpack], must not start with ''.","index_uuid":"na","index":"_xpack"}],"type":"invalid_index_name_exception","reason":"Invalid index name [xpack], must not start with ''.","index_uuid":"na","index":"_xpack"},"status":400}"}


(Bhavya R M) #2

Hello,

Have you set "xpack.security.enabled: false" in your elasticsearch.yml too?

Our 6.3.0 stack came with changes because we opened the code for x-pack.
https://www.elastic.co/blog/elastic-stack-6-3-0-released. The default distribution comes without security. So - you will have disable it in both elasticsearch and Kibana.

Let me know if this helps.

Thanks,
Bhavya


(Bhavya R M) #4

Did you uninstall x-pack from both your ES and Kibana ?

Thanks,
Bhavya


(Zelfapp) #5

I'm connecting to a remote host where my ES instance exists. I don't have control over the hosting company's ES instance or the elasticsearch.yml. On my local system I only installed kibana 6.3.2. I never installed the xpack plugin.

With xpack.security.enabled: false in my kibana.yml I now get the attached screenshot.


(Bhavya R M) #6

@jbudz how do I help this user?

Thanks,
Bhavya


(Zelfapp) #7

My original post was confusing. I do have ES installed locally as well, but with kibana, I am not connecting to my localhost ES, I am connecting to a remote host ES instance. Locally, if I point kibana to my localhost I am not having the xpack issue at all. I can connect and use DevTools, etc. Only an issue when I'm trying to connect to the remote host ES instance. Hopefully, I'm less confusing at this point.


(Bhavya R M) #8

You are fine. I don't think this is going to work if you cannot uninstall x-pack from your remote es and make sure both Kibana and ES are on the same version and distribution.


(Zelfapp) #9

From my host: "Our Elasticsearch cluster however does not use X-pack, and disabling it for your local Kibana instance might be the way to go."


(Jon Budzenski) #10

Hey,

By default we bundle x-pack with kibana as of 6.3, so there's a license check running and it's getting confused. You'll probably want the open source distribution, which can be found at https://www.elastic.co/downloads/kibana-oss.


(Zelfapp) #11

Like magic. OSS solved the issue. Thank you.


(system) #12

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.