Load metricbeat sample dashboards in 6.1.2


(Ravi) #1

just wondering so many options changed in ES 6.1.2 version wondersing how to load beats-dashboards-6.1.2.zip now

previously in 5.X followed like this

[root@localhost]# pwd
/usr/share/metricbeat/scripts
[root@localhost]# ./import_dashboards -file /root/beats-dashboards-5.5.1.zip -es http://10.251.33.130:8888 -user XXXX -pass XXXX

In documents mentioned in little confusion any help would be great

https://www.elastic.co/guide/en/beats/metricbeat/6.1/configuration-dashboards.html


(Ravi) #2

Figured :slight_smile:

-- Edit metricbeat.yml at /etc/metricbeat and there setup the config as :

setup.kibana:
  host: "localhost:5601"
  #Add your ES IP

And change Elasticsearch output as below:
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["localhost:9160"]
    # Add your ES details

-- Then run from /etc/metricbeat
/usr/share/metricbeat/bin/metricbeat setup --dashboards

you might get an error as :

Exiting: Error importing Kibana dashboards: fail to import the dashboards in Kibana: Error importing directory /usr/share/metricbeat/bin/kibana: No directory /usr/share/metricbeat/bin/kibana/default

-- For this case it seems kibana dir is present under /usr/share/metricbeat but it is looking at /usr/share/metricbeat/bin , so copy the kibana dir at bin folder and run the command again.

cp -r /usr/share/metricbeat/kibana /usr/share/metricbeat/bin/
[root@elk-cclab38 metricbeat]# pwd
/etc/metricbeat
[root@elk-cclab38 metricbeat]# /usr/share/metricbeat/bin/metricbeat setup --dashboards
Loaded dashboards
[root@elk-cclab38 metricbeat]#

(Andrew Kroh) #3

I think the commands you were looking for are in Step 4: Set up the Kibana dashboards.

The main difference from what you did is in the command. You executed:

/usr/share/metricbeat/bin/metricbeat setup --dashboards

but you should execute:

metricbeat setup --dashboards

By running just metricbeat your shell will find /usr/bin/metricbeat on the PATH. This configures the -path.* options correctly so you can run it from any directory.


(Aymen Jmal) #4

I added the setup.dashboards.enabled: true to my config file 'equivalent to command: /usr/share/metricbeat/bin/metricbeat setup --dashboards. Kibana dashboards successfully loaded but when i connect to kibana i can not find my data ? I have selected the right index mypattern-*

Compared to normal method, I just modified setup.dashboards.index and output.elasticsearch: index.
I added also a new template

setup.template.enabled: true
setup.template.name: "mypattern"
setup.template.pattern: "mypattern-*"

thanks,


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.