Logstash-5.6.2 jruby error


(Sidra Farooq) #1

not able to run logstash keep on getting jrudy error the below image show the details

using windows 10 and java 9


(Guy Boertje) #2

Logstash uses Jruby
Logstash 5.x uses versions 1.7.2x of jruby
JRuby 1.7.X is not compatible with Java 9.
JRuby 9.2 is the target version for Java 9 compatibility:


Logstash 6.0.0 (in RC phase) uses JRuby 9.1.13.0

Logstash will run on Java 9 in the future.

Now, you must use Java 8.


(Sidra Farooq) #3

okay .. will be using java 8 then ..

Thank you


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.