Logstash 6.4.2 java.lang.IllegalStateException (LoadError) Unsupported platform: x86_64-windows

can anyone please suggest steps to overcome this unsupported platform error

Hi @vamsi11,

Could you please tell me that on which window version you are installing logstash??

Also, Please find below link for ELK support matrix.
https://www.elastic.co/support/matrix

Regards,
Harsh Bajaj