Logstash 6.6 - Cannot install logstash-filter-geoip plugin :ERROR

I attempted to install the logstash-filter-geoip plugin via proxy.
But installed Faild.

I set and run setting http_proxy and https_proxy,but still it did not go well..
https://www.elastic.co/guide/en/logstash/current/working-with-plugins.html

Is there something wrong with the procedure?

◆Logstash-version:6.6.0
◆COMMAND: sudo bin/logstash-plugin install logstash-filter-geoip
◆ERROR: Something went wrong when installing logstash-filter-geoip , message: Failed to open TCP connection to artifacts.elastic.co:443 (execution expired)

Links of similar events.


With 6.6 I would expect geoip to be bundled, so you do not need to install it.

Does thread not help you?

as far as I can see it is the same problem..

Thank you for your reply.
I mistake to remove geoip plugin.
So, I have reinstalled it.

Thank you always and always.

I try edit the file But it did not go well.

‘’‘
/usr/share/logstash/bin/logstash-plugin
’‘’

Is there another way?
There is only offline installation.....

Why not just re-install logstash then, assuming you have the package locally. That should fix your plugin problem. Make sure you backup your config...

@pjanzen
Thanks!!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.