Logstash 6.x - Cannot configur logstash-input-jdbc plug in :ERROR

I cannot configu logstash -input-jdbc plug in

./logstash-plugin install logstash-input-jdbc
ERROR: Something went wrong when installing logstash-input-jdbc, message: Failed to open TCP connection to ar
ifacts.elastic.co:443 (execution expired)

Can you connect to https://artifacts.elastic.co with your browser? Do you need to configure logstash-plugin to use a proxy?

I had no problems with connecting via browser to https://artifacts.elastic.co

Since you mentioned proxy, I tried this out of the office at home with no VPN an it worked. So it must have been a proxy issue, not sure what everything else at work I can get to.

We have the same problem with installing a logstash plugin for Version 6.0.0-rc1 behind a proxy.

We have scripts in place that automatically prepare a logstash for each new release of the stack. Those scripts work with all versions up to 5.6.3, but stopped working with Version 6.0.0-rc1. They gave the above mentioned error "Failed to open TCP connection to artifacts.elastic.co:443 (execution expired)".

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.