Cannot install local plugin without internet connection


#1

I'm trying to install a locally built plugin but for some reason it's trying to connect to artifacts.elastic.co:

$ sudo bin/logstash-plugin install /path/to/my/plugin-1.0.0-java.gem
ERROR: Something went wrong when installing /path/to/my/plugin-1.0.0-java.gem, message: Failed to open TCP connection to artifacts.elastic.co:443 (execution expired)

This machine isn't connected to the internet so obviously this failed. My question is why do I need internet access to install a locally built plugin?


(Sindre) #2

I also have the same problem.
I even tried with --local option but it didn't help.
Did you find any solution?


#3

Unfortunately I did not. I had to set up a proxy on my machine to get it to connect to artifacts.elastic.co. I should probably report this bug.


#4

I am running into a similar issue with logstash plugins installing, but logstash will not start after the plugin is installed stating that logstash cannot find the plugin, but when I run the command to list installed plugins, the downloaded one is on that list :confused: very frustrating. I have tried multiple downloadable plugins and none of them are "found" by logstash, but show on the list of installed plugins :confused:


(Sindre) #5

motts: With internet connection inactive?


#6

With internet I am having issues installing any plugins. I have 2 threads open, but none of them have been looked at. One closed because it was open too long without a comment :frowning_face:

and


(Sindre) #7

Motts: Because you are installing it incorrectly. What OS are you using?

Here is how to install a filter on Ubuntu Linux, see step nr 4 here:
https://nettport.com/en/kibana/logstash/logstash_installation_ubuntu.php


#8

I am using CentOS and LogStash 6.2.

I am installing the plugins the same way I have for LS 2.4 and 5.6, and those version never had issues. When I migrated to 6.x, I began to have problems with installing plugins though LS would say they were installed.

Adding plugins to your deploymentedit
The most common situation when dealing with plugin installation is when you have access to internet. Using this method, you will be able to retrieve plugins hosted on the public repository (RubyGems.org) and install on top of your Logstash installation.

bin/logstash-plugin install logstash-output-kafka
Once the plugin is successfully installed, you can start using it in your configuration file.

REF: https://www.elastic.co/guide/en/logstash/6.2/working-with-plugins.html

So, I should be installing the plugin with

/bin/logstash-plugin install logstash-filter-alter

Logstash will run fine up until it gets to code that has a downloaded filter, then it will crash saying the filter is not installed. If I comment out the downloaded filter in the filter file, LS will restart without issues.

Here is logstash saying the filter is there:

[root@elk-logstash-lab02 /]# /usr/share/logstash/bin/logstash-plugin list filter
logstash-filter-aggregate
logstash-filter-alter
logstash-filter-anonymize
logstash-filter-cidr

Here is the error:

[2018-05-16T11:05:09,854][ERROR][logstash.plugins.registry] Tried to load a plugin's code, but failed. {:exception=>#<LoadError: no such file to load -- logstash/filters/alter>, :path=>"logstash/filters/alter", :type=>"filter", :name=>"alter"}
[2018-05-16T11:05:09,859][FATAL][logstash.runner ] The given configuration is invalid. Reason: Couldn't find any filter plugin named 'alter'. Are you sure this is correct? Trying to load the alter filter plugin resulted in this error: no such file to load -- logstash/filters/alter

Very frustrating.


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.