Logstash-codec-plain is broken dependency in Logstash version 7.15.2

I am trying to install Logstash-output-loki plugin, the logstash-codec-plain causes a dependency conflict, looks like this plugin is a broken dependency.

My Logstash version is 7.15.2, this problem is not happening in Logstash 7.7.0
This makes me thing its a bug in this version.
Is there any way to get around this problem in this version? Any help please

//  /usr/share/logstash/bin/logstash-plugin install logstash-output-loki
Using JAVA_HOME defined java: /home/SaidaMeftah/.jabba/jdk/amazon-corretto@1.11.0-7.10.1
WARNING, using JAVA_HOME while Logstash distribution comes with a bundled JDK
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Validating logstash-output-loki
Resolving mixin dependencies
Installing logstash-output-loki
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-codec-plain":
  In snapshot (Gemfile.lock):
    logstash-codec-plain (= 3.1.0)

  In Gemfile:
    logstash-codec-plain

    logstash-input-beats was resolved to 6.2.1, which depends on
      logstash-codec-plain

    logstash-input-jms was resolved to 3.1.2, which depends on
      logstash-codec-plain (~> 3.0)

    logstash-output-loki was resolved to 1.0.3, which depends on
      logstash-codec-plain (= 3.0.6)

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict. 

The issue is not with logstash-codec-plain, but with logstash-output-loki, which is a third party plugin.

The version of the logstash-codec-plain was at version 3.0.6 until 7.15, where the version is now 3.1.0, the loki output has a different version as a dependency.

There is already an issue in the grafana loki github about this, you should check with them as this is not a logstash issue.

1 Like