Logstash Custom Plugin can't add the local dependencies

We use artifactory as the gem source and we have some locally built gems.

I tried to use one of the gem in the customized logstash filter plugin as a runtime dependency and tried to call inside the filter, which runs fine with the specs, but It fails at the installation of plugin in the logstash, mentioning no gem found in Vendor/Cache.

So, isn't the design doesn't support the external gems in the plugin? Please let me know as I got to change my plugin design if that's not the case.

Here is the error log:

Bundler::VersionConflict: Bundler could not find compatible versions for gem "rubocop":
  In Gemfile:
    logstash-filter-kins_logs (= 0.2.0) java depends on
      rubocop (~> 0.44.1) java
Could not find gem 'rubocop (~> 0.44.1) java', which is required by gem 'logstash-filter-kins_logs (= 0.2.0) java', in any of the sources.


Hi @magnusbaeck - any help on this please. Thanks in advance.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.