Logstash didn't show at index pattern on kibana. [SOLVED]


#1

so, i have an assignment. to make a dashboard using elk stack elasticsearch, logstasg , kibana, and i must catching log data from port 10514. i've tried a few things to set up like
input {
udp = 10514

or
input {
beats {

but it still can't catch anything or connect to port 10514 and show at index pattern. is there any way that i can try or use to do this? thankyou.


Logstash on port 10514. need help for my assignment, thankyou
(kulkarni) #2

Hi Amity

I do not think this is an issue with the products. This issue is so generically phrased, I cannot understand it. May be you could be more specific? Ex: what environments you run on , is there firewall involved? etc...This will isolate the issue.

Thanks
Rashmi


#3

i installed it on centos 7 server on putty, using elasticsearch, kibana, logstash 5.5 . no firewall i think. cause when i check iptables, there's no iptables. i mean the problem is, when i try to configure pattern on kibana management. when i try in dex name logstash-* " it shows unable to fetch mapping. do you have indices matching pattern? ". i try to check indices, there's no logstash, but logstash already running. how can i fix this? thankyou.

here's the screnshoot


(kulkarni) #4

What happens if you issue this command in your command line ? If I go to http://localhost:9200/_cat/indices do you see logstash index pattern there ? This is directly returned from ES. The .kibana index holds Kibana related data, and if this is the only index you have there is no data available that Kibana can visualize.

Thanks
Rashmi


#5

i don't know why, but it is already work and show logstash index on kibana and indices. at first it was okay to create logstash index, but when i try to remove it, it gave me this and elasticsearch unreachable but the service is running:

Error: Request Timeout after 30000ms
at http://10.10.10.4:5601/bundles/kibana.bundle.js?v=15382:12:4431
at http://10.10.10.4:5601/bundles/kibana.bundle.js?v=15382:12:4852

and turns out elasticsearch changed from green to red.

how can i fix this? thankyou so much.


(kulkarni) #6

If this is an experimental cluster and you have the permission to delete the data directory, I would advise you to stop your node and delete the data dir. Restart a clean node and reindex the data. After doing this, ES cluster health should be green. It can be verified by the command GET _cluster/health from the console.

( or) alternatively, you could just delete the logstash index pattern and reindex it again to see if this resolves the red state of the cluster. curl -XDELETE "http://localhost:9200/.kibana/index-pattern/pattern_name"

Let me know if this helps
Rashmi


(kulkarni) #8

Hi Amity

I would suggest you to post your question in a new thread - in the #logstash discuss channel here https://discuss.elastic.co/c/logstash
Some one more experienced in logstash config can help you better there.

Thanks
Rashmi


#9

okaaay, i'm gonna make it there. thankyou for your help ^^


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.