Logstash does not deliver Logs anymore

This is kind of an emergancy, i tried to change my /etc/Logstash/conf.d/10-syslog....config in my ELK-Cluster. As i was nearly finished, i noticed that it would not work the way i tried it. So i rolled back ( i preped some backup files of the config beforehand) and restarted the service, but now there are no Logs comming in Kibana? Do i need to restart other services as well?


Ok what i found out :
After the restart, the Port 5044/5045 were both closed on my Logstash Nodes, when i try to reopen them, they get closed within a second.
Any ideas how to solve this?

The solution to this issue was that a colleague of me changed some config in the logstash.yml file.

The line was
"# Bind port for the metrics REST endpoint, this option also accept a range"
"# (9600-9700) and logstash will pick up the first available ports."
" http.port: 9600-9700"

in which he uncommented http.port: 9600-9700.
This bound the log delivery to other ports, ending in a connection refusal on 5044 & 5045.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.