Logstash does not send data to elastic search

I am trying to run elastic search to send data to Amazon ES. Have configured everything including Amazon Plugin but it is not sending anything to Amazon ES.

After Pipeline Main Started nothing happpen

1 Like

Hi Manish,

Seems there is a problem in receiving the logs at your Logstash node. If Nothing happens after Pipeline Main starts, might be a signal that you are not receiving logs. To test whether you are receiving logs or not try to add the stdout plugin in output section.

output {
stdout { codec => rubydebug }

And then try re-running the Logstash using the -f options. If you see indexed logs in the Command Line, it means you are receiving logs at logstash node and it is successfully parsing them. If still it doesn't display anything, you have to check with logstash.

Tried. Still no luck.

This actually means you are having issues with receiving logs at Logstash. You have to check whether you have correct configuration at client devices and test whether you are able to ping from there to the node of Logstash.
I faced the same issue for long and has multiple reasons behind it.

try these of my tricks.

  1. Once you start the logstash, do check whether it is LISTEN ing on the ports you specified in input section.
  2. Check whether you are not running two instances of the same service Logstash by mistake (I actually did that sort of mistakes.)

Also try posting your configuration, so that more things can be suggested.