Logstash does not start; says "could not find jruby in ..."


(Humberto) #1

Best regard. I would like to know why it does not start the Logstash (version 6.1.1) that I have installed locally. After locating in DOS in the directory where I have it installed ("c: \ Elastic Stack \ logstash-6.1.1"), when I give the instruction "bin \ logstash" it produces a message with the following. two lines:

The system can not find the path specified.
"could not find jruby in c: \ Elastic Stack \ logstash-6.1.1 \ vendor \ jruby"

Also, if located in the directory of the installation I give the instruction "bin \ logstash -e 'input {stdin {}} output {stdout {}}'" (to test the installation), it produces the same error message with the same two lines that I already indicated.

Previously I have already started both 'Elasticsearch' (version 6.1.0) and 'kibana' (version 6.1.1). I have Windows 7 Home Basic operating system.

I'm just beginning to know and use these tools. The next thing I have planned to do is install 'Beats'.

I would like to know what is the reason why Logstash does not start, what I am doing wrong or what I need to do.

I am very grateful to you in advance for your collaboration.


(Humberto) #2

Hola a todos. Investigando y ojeando en internet, encontré que el problema era porque el primer directorio de la ruta contenía un espacio en blanco; remplacé el espacio por un "_" y ya no tengo el problema motivo de este tema. Gracias de todos modos.


#3

Hi enrique3000- I ran into this on my Windows 2012 R2 server. Logged an issue to logstash github: https://github.com/elastic/logstash/issues/8901

Hope this fixes your problem...


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.